[phenixbb] Rosetta installation problems (II)

Luca Jovine Luca.Jovine at ki.se
Sun Oct 7 02:43:25 PDT 2018

On 6 Oct 2018, at 21:45, Billy Poon <BKPoon at lbl.gov<mailto:BKPoon at lbl.gov>> wrote:

Hi Luca,

Please try the latest version of Rosetta 3.10. There was a bug with macOS 10.13.6 that is fixed. I have tested Rosetta 3.10 on macOS 10.13.6 and Xcode 10. The rosetta.run_tests step completes without using massive amounts of memory. Also, if you use the GUI for phenix.rosetta_refine, please use the latest nightly build, dev-3283. There was a bug where the final R-values are not stored, which caused the GUI to crash.

Billy K. Poon
Research Scientist, Molecular Biophysics and Integrated Bioimaging
Lawrence Berkeley National Laboratory
1 Cyclotron Road, M/S 33R0345
Berkeley, CA 94720
Tel: (510) 486-5709
Fax: (510) 486-5909
Web: https://phenix-online.org

Hi Billy,

Thanks for the follow-up, I tried and confirm that the combination of Rosetta 3.10 + PHENIX dev-3283 indeed works fine on Mac OS 10.13.6.

However, I then tried the same on ubuntu (16.04) and in this case I got the following:

> which rosetta.run_tests
> rosetta.run_tests
End of input processing
Traceback (most recent call last):
 File "/usr/local/phenix/phenix-dev-3283/build/../modules/phenix/phenix/command_line/rosetta_refine.py", line 304, in <module>
   run(sys.argv[1:], create_dir=True)
 File "/usr/local/phenix/phenix-dev-3283/build/../modules/phenix/phenix/command_line/rosetta_refine.py", line 143, in run
   scripts_cmd = phenix.rosetta.refine.find_scripts_command()
 File "/usr/local/phenix/phenix-dev-3283/modules/phenix/phenix/rosetta/refine.py", line 26, in find_scripts_command
   return find_rosetta_command("rosetta_scripts.python.", **kwds)
 File "/usr/local/phenix/phenix-dev-3283/modules/phenix/phenix/rosetta/refine.py", line 50, in find_rosetta_command
   rosetta_cmd = search_path(rosetta_bin)
 File "/usr/local/phenix/phenix-dev-3283/modules/phenix/phenix/rosetta/refine.py", line 31, in search_path
   for node in os.listdir(path) :
OSError: [Errno 2] No such file or directory: '$PHENIX_ROSETTA_PATH/main/source/bin'

...but directory $PHENIX_ROSETTA_PATH/main/source/bin does exist, and it’s populated:

ls -l $PHENIX_ROSETTA_PATH/main/source/bin
total 2292
lrwxrwxrwx 1 luca luca  92 Oct  7 10:29 AbinitioRelax.default.linuxgccrelease -> ../build/src/release/linux/4.15/64/x86/gcc/5.4/default/AbinitioRelax.default.linuxgccrelease
lrwxrwxrwx 1 luca luca 101 Oct  7 10:54 zinc_statistic_generator.python.linuxgccrelease -> ../build/src/release/linux/4.15/64/x86/gcc/5.4/python/zinc_statistic_generator.python.linuxgccrelease

Do you have any idea of why this happens?

Thanks again,


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://phenix-online.org/pipermail/phenixbb/attachments/20181007/5ec9575e/attachment.htm>

More information about the phenixbb mailing list