[phenixbb] phenix.find_blobs command problems

oleg at quantumbioinc.com oleg at quantumbioinc.com
Fri Jan 20 07:22:09 PST 2017

I tried to use phenix.find_blobs command but it ended up with a Python crash. Any thoughts?

Thanks a lot


P.S. I tried to attached the input files but it seems to be over the allowed message size

phenix.find_blobs protein_pdb_file_name=1LRI-H_refine_001.pdb map_coeffs_file_nam=1LRI-H_refine_001.mtz
#phil __OFF__

#phil __ON__
find_blobs {
 input {
   protein_pdb_file_name = "1LRI-H_refine_001.pdb"
   data_file_name = None
   map_coeffs_file_name = "1LRI-H_refine_001.mtz"
 output {
   blob_number = None
 options {
   random_seed = 0
   density_contour = 2.5
#phil __END__

 Random number seed:  3628800

 Adding PDB model from 1LRI-H_refine_001.pdb
Traceback (most recent call last):
 File "/home/oleg/phenix-1.11.1-2575/build/../modules/phenix/phenix/command_line/find_blobs.py", line 169, in <module>
   run( tuple(args) )
 File "/home/oleg/phenix-1.11.1-2575/build/../modules/phenix/phenix/command_line/find_blobs.py", line 162, in run
   rc = execute(params)
 File "/home/oleg/phenix-1.11.1-2575/build/../modules/phenix/phenix/command_line/find_blobs.py", line 98, in execute
 File "/home/oleg/phenix-1.11.1-2575/modules/phenix/phenix/ligands/blob_finding_class.py", line 25, in setup_blobs
 File "/home/oleg/phenix-1.11.1-2575/modules/phenix/phenix/ligands/DensityBlobsClass.py", line 14, in __init__
   self.map_residue = self.data_map["fofc_fft_map"] # fft map
TypeError: 'fft_map' object has no attribute '__getitem__'

More information about the phenixbb mailing list