[phenixbb] Problems building source

Jason Swails jason.swails at gmail.com
Wed Oct 1 09:10:42 PDT 2014

Hi everyone,

I'm a new user that is trying to get Phenix installed.  I'm trying the
source build since I want to poke around with a little development.  I
haven't had much luck in this endeavor (I'm fairly competent when it
comes to building especially scientific software from source).

What I tried was untarring the 1.9-1692 release tarball and
running ./install in that directory.

The first thing to fail was Imaging, and the build log complained of a
missing freetype/fterrors.h header.  On my machine, that file is located
in /usr/include/freetype2/fterrors.h.  OK, so I
symlinked /usr/local/include/freetype to /usr/include/freetype2 and
tried again. Imaging succeeded, but then I noticed that Phenix tried to
compile its own version of freetype later (!).  I'm curious as to why it
would either a) not build freetype first so Imaging could use it or b)
why it would try to build freetype at all when it already has to be

Anyway, after that was done, I got another problem when the install
process got to Pango.  Then I get the error:

fribidi_config.h:1:18: fatal error: glib.h: No such file or directory

But glib has already been installed according to the Phenix install log
(and I have it installed on my system, too).  There's a glib.h in
tmp/glib-2.12.11/glib/glib.h (but that directory is never added to the
include search path), and also in /usr/include/glib-2.0/glib.h.

I admit that the install process has me puzzled (for instance, I can't
figure out how to augment CFLAGS for the Pango install to make it find
glib.h), and I feel that I'm playing a bit of whack-a-mole with the
build problems here...

Any help or advice regarding getting the source code built is


Jason M. Swails
Rutgers University
Postdoctoral Researcher

More information about the phenixbb mailing list