[phenixbb] Phenix.Rosetta_refine on Ubuntu 12.04 LTS

qwertgfdsa78 qwertgfdsa78 at gmail.com
Sat Nov 9 07:35:13 PST 2013

Hi All,

I tried Jan's tutorial and  finally I was able to install and
ran phenix.rosetta with test set 1yjp successfully.

However, when I tried my data, I always got

*"terminate called after throwing an instance of 'std::bad_alloc'"*

Google suggests maybe memory is not enough.
I used VirutalBox and assign 8gb memory to it.
My protein has ~3000 residues. I guess this will use more memory but how
much RAM I need?

Or the error is due to some other problem?

Thank for any inputs.


> ------------------------------
> Message: 3
> Date: Tue, 05 Nov 2013 14:26:00 +0100
> From: Jan Gebauer <jan.gebauer at uni-koeln.de>
> To: PHENIX user mailing list <phenixbb at phenix-online.org>
> Subject: Re: [phenixbb] Phenix.Rosetta_refine on Ubuntu 12.04 LTS
> Message-ID: <5278F1E8.9020602 at uni-koeln.de>
> Content-Type: text/plain; charset="utf-8"
> Hi David, hi all,
> I now managed to at least get a test refinement working. What I mostly
> changed was the Ubuntu version.
> I have no idea why, but I managed to get it to work on Ubuntu 10.04.
> In principle I installed 10.04 freshly in a virtualbox and from their it
> worked rather straight-forward.
> Here is how I proceeded in detail for those of you who are interested:
> 1) Setting up a Virtualbox 4.3.2 r90405 on Ubuntu 12.04.3.
> 2) Installing the 64bit version of Ubuntu 10.04 in a virtualbox (4
> processors / 90% speed cap / 4GB Ram /VT-x enabled)
> 3) Install VBoxAdditions
> 4) Update ubuntu (sudo apt-get update)
> 5) Installing g++ and zlib library (sudo apt-get install g++ zlib1g-dev)
> 6) Installing binary version of phenix-dev-1525 to
> /usr/local/science/phenix-dev-1525 (sudo ./install
> --prefix=/usr/local/science)
> 7) Unpack rosetta_2013_wk42_bundle to
> /usr/local/science/rosetta_2013_wk42_bundle
> 8) set rossetta variables by inserting them at the start of
> /usr/local/science/pheninx-dev-1525/phenix_env.sh (just in line 3ff):
> export PHENIX_ROSETTA_PATH=/usr/local/science/rosetta_2013wk42_bundle
> export ROSETTA3_DB=/usr/local/science/rosetta_2013wk42_bundle/main/database
> export
> PATH=$PATH:/usr/local/science/rosetta_2013wk42_bundle/main/source/bin
> 9) assign ownership to active user (sudo chown gebauer:gebauer
> /usr/local/science/ -R)
> 10) Compile it (phenix.build_phenix_interface nproc=4)
> It should run without problems
> Testing:
> 1) Create a new directory (mkdir test && cd test)
> 2) Download testset (suggested by Nat: phenix.fetch_pdb --mtz 1yjp)
> 3) Run rosetta_refine (phenix.rosetta_refine 1yjp.pdb 1yjp.mtz nproc=4)
> In my case rFree dropped from 18.21 to 14.90. It's not a low resolution
> dataset, but it show that it general works and lowRes would potentially
> take to long for a mere testing
> My real data are still being processed so I have no idea how well it
> will works... only thing I found out already:
> 4.5 GB RAM for 4 processes calculating ~500Aa via rosetta seems not to
> be enough. I thereby reduced my "real run" to only one processor...
> Regards,
> Jan
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://phenix-online.org/pipermail/phenixbb/attachments/20131109/0981603e/attachment.htm>

More information about the phenixbb mailing list