[phenixbb] Unable to install phenix 1.8.1-1168 on Scientific Linux 6.3 64 bits

Engin Ozkan eozkan at stanford.edu
Sun Jan 27 13:54:33 PST 2013

I just installed yesterday the latest nightly build on our Scientific Linux 6 (6.3, I believe) machine using the 64-bit FC3 installer. No problems. 


Engin Özkan
Garcia Lab,  Stanford

-------- Original message --------
From: Nathaniel Echols <nechols at lbl.gov> 
To: PHENIX user mailing list <phenixbb at phenix-online.org> 
Subject: Re: [phenixbb] Unable to install phenix 1.8.1-1168 on Scientific Linux 6.3 64 bits 
On Fri, Jan 25, 2013 at 4:15 PM, Davi de Miranda Fonseca
<davi.fonseca at ntnu.no> wrote:
> I installed Scientific Linux 6.3 64 bits, updated everything and installed a
> couple of things that I think would be necessary. Then I uncompressed
> phenix-installer-1.8.1-1168-intel-linux-2.6-x86_64-fc3.tar to /tmp and tried
> to install, however I got some errors. Hence, I installed a couple more
> things and tried installing again.

The first thing to try when something like this happens is to download
one of the other 64-bit installers.  In most cases the fc3 build is
preferred, but there are some newer distributions where an installer
built on a more recent version of Fedora is preferable.  I would start
with fc8 and work your way up.

The second thing to try, if all of the binary installers fail, is to
install from source.

> ***** And here are the last lines of
> /tmp/phenix-installer-1.8.1-1168/build-binary/intel-linux-2.6-x86_64/scientifix/log/binary.log:
> /usr/local/phenix-1.8.1-1168/build/intel-linux-2.6-x86_64/base/bin/python:
> /lib64/libc.so.6: version `GLIBC_2.14' not found (required by
> /usr/local/phenix-1.8.1-1168/build/intel-linux-2.6-x86_64/base/bin/python)
> By the way, Scientific linux 6.3 comes with glibc 2.12.

To be honest I simply don't understand library versioning issues - the
Fedora 3 machine we build that installer on currently has glibc 2.3,
so I don't know where the GLIBC_2.14 is coming from.  I think it will
be significantly more work to figure out a workaround than trying the
other installers, though.  Unfortunately we do not actually have a
Scientific Linux system here - the closest I could find was CentOS
6.2, and that works okay.

phenixbb mailing list
phenixbb at phenix-online.org
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://phenix-online.org/pipermail/phenixbb/attachments/20130127/3ba82849/attachment.htm>

More information about the phenixbb mailing list