[phenixbb] Unable to install phenix 1.8.1-1168 on Scientific Linux 6.3 64 bits

Davi de Miranda Fonseca davi.fonseca at ntnu.no
Fri Jan 25 16:15:01 PST 2013

Dear all,

I am unable to install phenix 1.8.1-1168 on Scientific Linux 6.3 64 
bits. Hence, I would greatly appreciate any 2 cents (or diamonds).

I installed Scientific Linux 6.3 64 bits, updated everything and 
installed a couple of things that I think would be necessary. Then I 
uncompressed phenix-installer-1.8.1-1168-intel-linux-2.6-x86_64-fc3.tar 
to /tmp and tried to install, however I got some errors. Hence, I 
installed a couple more things and tried installing again.
This time it went through most of the installation but failed during the 
configuration of phenix packages.

**** Here is my shell output:

[root at scientifix phenix-installer-1.8.1-1168]# ./install

                       PHENIX Installation

                       version: 1.8.1
                   release tag: 1168
                  machine type: intel-linux-2.6-x86_64
           source machine type: intel-linux-2.6-x86_64
                    OS version: linux
                    user shell: /bin/bash
                   destination: /usr/local

                      Installing from binary bundle

bundle file:
PHENIX installation source directory set to:
PHENIX installation target directory <PHENIX_LOC > set to:
PHENIX installation build directory set to:
   <PHENIX_LOC > /build/intel-linux-2.6-x86_64
PHENIX temporary build directory set to:
PHENIX installation log directory set to:

==== warning: "/usr/local/phenix-1.8.1-1168" already exists ====
==== warning: cannot determine installation time-stamp, proceeding ====

installing binary components

removing existing files in 
finding installed versions
finding binary versions
binary components up-to-date
the binary package will not be installed

setting environment

configuring PHENIX components

Error configuring: see 
for details

***** And here are the last lines of 

/lib64/libc.so.6: version `GLIBC_2.14' not found (required by 

By the way, Scientific linux 6.3 comes with glibc 2.12.

It might be too naive from me, but would it be possible to copy 
libc.so.6 from glibc-2.14 somewhere and use an option during the 
installation to point to it? Any better ideas? (Like a step-wise 
description used in successful installation of phenix in Scientific 
Linux 6.3 64)

Thank you for your time and help.


More information about the phenixbb mailing list