[phenixbb] mr_rosetta test failure

Thomas C. Terwilliger terwilliger at lanl.gov
Tue May 31 13:39:47 PDT 2011

Hi Laurie,

I'm sorry for the problem!  This is a little difficult to debug because
the problem has to do with Rosetta and Phenix, not just Phenix.

What happens with this (if you are not using a mac, change the last part
of this command to match what is in your rosetta_source/bin/ directory):


This is the command to run Rosetta by itself.  If this doesn't work, then
there is some kind of problem in the installation.  Let me know and I will
put you in touch with someone from the Rosetta team to help debug it.

All the best,
Tom T

>> We installed latest phenix and latest rosetta last week.  I ran test
>> script:
>> phenix_regression.wizards.test_command_line_rosetta_quick_tests and got
>> the
>> test failing at the prerefine because of missing shared libraries, as
>> shown
>> below in the FAQ (italics).
>> I tried again in both bash & csh after setting or exporting the
>> environment
>> variables shown below, but got the same exact error.  If I do printenv the
>> shell sees the new env var.
>> What should I try next?
>> THanks so much
>> Laurie Betts & CD Poon
>> University of North Carolina
>> *Why does mr_rosetta bomb and say "error while loading shared libraries:
>> libdevel.so: cannot open shared object file: No such file or directory ?
>> This may indicate that somewhere your system is defining the shared
>> libraries that Rosetta needs, and these are for a place that is not where
>> Rosetta expects them to be. You can try to ignore the previous definitions
>> this way: If you are using the bash or sh shells:
>> or csh (C-shell):
>> in the script where you run mr_rosetta, or before you run it from the
>> command line.
>> *
>> _______________________________________________
>> phenixbb mailing list
>> phenixbb at phenix-online.org
>> http://phenix-online.org/mailman/listinfo/phenixbb

More information about the phenixbb mailing list