[phenixbb] Problem with version 1.7.1-743 on OSX

Miguel Ortiz Lombardía miguel.ortiz-lombardia at afmb.univ-mrs.fr
Tue May 3 01:11:54 PDT 2011

Le 02/05/11 20:03, Nathaniel Echols a écrit :
> 2011/5/2 Miguel Ortiz Lombardía <miguel.ortiz-lombardia at afmb.univ-mrs.fr>:
>> 1/ the same pdb and mtz files work perfectly in the same Mac computer
>> providede I run phenix.refine from the command line
>> 2/ they also work fine if I run phenix.refine in a linux computer (in
>> this case they work from both GUI and command line)
>> 3/ Any file downloaded from the PDB gives the same negative result
>> So, it is clearly a GUI problem on the Macs, which is not the same than
>> saying that the problem is *in* the Phenix GUI: it could be yet another
>> side-effect of an Apple software update...
> It turned out to be a side effect of using the newer version of
> wxPython in the 64-bit Mac builds.  The problem is with the French
> language setting on your computer, which change some of the formatting
> conventions (including, I suspect, using ',' instead of '.' for
> decimal numbers).  I was able to reproduce this on a test system, but
> only with the 64-bit installer - the 32-bit version works fine,
> presumably because it is using an earlier release of wxPython.  (This
> also explains why the GUI in the Linux build on your systems works
> okay.)
> The launchers force the language setting to be the same as far as the
> command-line code is concerned, but I can only assume that wxPython
> now overrides this, on Mac at least.  The solution to this,
> fortunately, is very simple - I just need to set the language
> localization again when the GUI starts.  The next nightly build will
> have the fix, but if you want to patch 1.7.1, I've attached the file
> you need.  Use this command:
> patch $PHENIX/phenix/wxGUI2/App.py App.patch
> Thanks for catching this.  I'm assuming the MTZ file issue has the
> same cause, but if the problem doesn't completely go away after
> patching or updating, please let us know.  (Oh, and I suspect REEL
> will have the same problem if started from the command line rather
> than the main GUI - I'll fix that next.)
> -Nat

Thank you, Nat.

This appears to have been the problem since your patch fixes it. It is
also consistent with the fact that I set these variables in the general
bashrc file:

# To avoid decimal separator problems

# To get files sorted by date in Coot

that explain why the jobs could run properly from the command line.

Best regards,


Architecture et Fonction des Macromolécules Biologiques (UMR6098)
CNRS, Universités d'Aix-Marseille I & II
Case 932, 163 Avenue de Luminy, 13288 Marseille cedex 9, France
Tel: +33(0) 491 82 55 93
Fax: +33(0) 491 26 67 20
mailto:miguel.ortiz-lombardia at afmb.univ-mrs.fr

This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

More information about the phenixbb mailing list