[phenixbb] Problem with version 1.7.1-743 on OSX

Nathaniel Echols nechols at lbl.gov
Mon May 2 11:03:22 PDT 2011

2011/5/2 Miguel Ortiz Lombardía <miguel.ortiz-lombardia at afmb.univ-mrs.fr>:
> 1/ the same pdb and mtz files work perfectly in the same Mac computer
> providede I run phenix.refine from the command line
> 2/ they also work fine if I run phenix.refine in a linux computer (in
> this case they work from both GUI and command line)
> 3/ Any file downloaded from the PDB gives the same negative result
> So, it is clearly a GUI problem on the Macs, which is not the same than
> saying that the problem is *in* the Phenix GUI: it could be yet another
> side-effect of an Apple software update...

It turned out to be a side effect of using the newer version of
wxPython in the 64-bit Mac builds.  The problem is with the French
language setting on your computer, which change some of the formatting
conventions (including, I suspect, using ',' instead of '.' for
decimal numbers).  I was able to reproduce this on a test system, but
only with the 64-bit installer - the 32-bit version works fine,
presumably because it is using an earlier release of wxPython.  (This
also explains why the GUI in the Linux build on your systems works

The launchers force the language setting to be the same as far as the
command-line code is concerned, but I can only assume that wxPython
now overrides this, on Mac at least.  The solution to this,
fortunately, is very simple - I just need to set the language
localization again when the GUI starts.  The next nightly build will
have the fix, but if you want to patch 1.7.1, I've attached the file
you need.  Use this command:

patch $PHENIX/phenix/wxGUI2/App.py App.patch

Thanks for catching this.  I'm assuming the MTZ file issue has the
same cause, but if the problem doesn't completely go away after
patching or updating, please let us know.  (Oh, and I suspect REEL
will have the same problem if started from the command line rather
than the main GUI - I'll fix that next.)

-------------- next part --------------
A non-text attachment was scrubbed...
Name: App.patch
Type: application/octet-stream
Size: 408 bytes
Desc: not available
URL: <http://phenix-online.org/pipermail/phenixbb/attachments/20110502/999afd4d/attachment.obj>

More information about the phenixbb mailing list