[phenixbb] Problem with version 1.7.1-743 on OSX

Miguel Ortiz Lombardía miguel.ortiz-lombardia at afmb.univ-mrs.fr
Mon May 2 08:11:04 PDT 2011

Hi Nat,

I'm using the command-line installer for Mac, as I have always done. I
typically run it with:

sudo ./install.sh --no-apps --prefix=/some/where

It is not a problem with the pdb file or with the mtz:

1/ the same pdb and mtz files work perfectly in the same Mac computer
providede I run phenix.refine from the command line
2/ they also work fine if I run phenix.refine in a linux computer (in
this case they work from both GUI and command line)
3/ Any file downloaded from the PDB gives the same negative result

So, it is clearly a GUI problem on the Macs, which is not the same than
saying that the problem is *in* the Phenix GUI: it could be yet another
side-effect of an Apple software update...

To be complete, for a typical Mac here:

>uname -a
Darwin think.local 10.7.0 Darwin Kernel Version 10.7.0: Sat Jan 29
15:16:10 PST 2011; root:xnu-1504.9.37~1/RELEASE_X86_64 x86_64

>xcodebuild -version
Xcode 3.2.6
Component versions: DevToolsCore-1809.0; DevToolsSupport-1806.0
BuildVersion: 10M2518



Le 02/05/11 16:45, Nathaniel Echols a écrit :
> By the way, are you using the graphical or command-line installer for Mac?
> thanks,
> Nat
> On Mon, May 2, 2011 at 7:41 AM, Nathaniel Echols <nechols at lbl.gov> wrote:
>> 2011/5/2 Miguel Ortiz Lombardía <miguel.ortiz-lombardia at afmb.univ-mrs.fr>:
>>> Last Friday (April 29) we upgraded phenix to its most recent version
>>> (1.7.1-743). Installation went smoothly on both Mac (10.6.7 64-bit) and
>>> Linux (Ubuntu 10.10 64-bit) machines. However, we observe that we cannot
>>> use phenix.refine (I don't know for the rest of the applications) from
>>> the GUI on the Macs. phenix.refine does work from the command line, though.
>>> So, whenever we try to add a pdb in the GUI, we get this error message:
>>> This application does not support the file type for
>>> /path/to/the/file.pdb
>>> (format: txt)
>> I just tried about a dozen different PDB files and a few MTZs and I
>> couldn't reproduce this.  However, I only have the 32-bit version
>> installed on this computer; I will try the 64-bit version when I
>> arrive at the lab (although I'm pretty certain I tried loading PDB
>> files in the installed version sometime last week without issues).
>> The error you're seeing usually indicates some kind of formatting
>> problem with the PDB file that caused the PDB parser to fail (it will
>> default to reading it as a text file instead - not very helpful, I
>> know).  Could you please send me the file that is having this problem?
>> I'm not sure what the MTZ-related error means - it looks like the CCP4
>> library is choking on the CCP4 symop.lib, which is bizarre.  Those
>> extra spaces certainly shouldn't be there in the original file.  Could
>> you please also send me the file $PHENIX/ccp4io/lib/data/symop.lib?
>> thanks,
>> Nat
> _______________________________________________
> phenixbb mailing list
> phenixbb at phenix-online.org
> http://phenix-online.org/mailman/listinfo/phenixbb


Architecture et Fonction des Macromolécules Biologiques (UMR6098)
CNRS, Universités d'Aix-Marseille I & II
Case 932, 163 Avenue de Luminy, 13288 Marseille cedex 9, France
Tel: +33(0) 491 82 55 93
Fax: +33(0) 491 26 67 20
mailto:miguel.ortiz-lombardia at afmb.univ-mrs.fr

This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

More information about the phenixbb mailing list