[phenixbb] phenix.phaser params.eff labin problem

G P gysubscribe at gmail.com
Wed Jul 20 11:35:49 PDT 2011

Hi Nat,

Thank you so much! That's cool. I just wrote a None to that solution and it
works!! Now I have some new problems:

At beginning, I only have phenix installed. I do not have CCP4 installed.
Then I run "phenix.phaser params.eff" to call phenix run phaser from script
params.eff. It works well.

Then, I installed CCP4 with its own phaser inside. Then I run again
"phenix.phaser params.eff". The computer start to import files (should be
some libraries and supporting files, not input data) from CCP4 installation
directory. It seems so strange for me.

And because some of the .so files in CCP4 directory are for 32bit,
phenix.phaser gave me error message: wrong ELF class: ELFCLASS32 and refused
to keep running.

Is there anyway to set some kind of PATH variables to let phenix.phaser
params.eff run like without CCP4 installed. (which I did at beginning).

Sorry for so many questions. Don't worry to reply if you do not have time.
I fully understand and thanks a lot for your reply.


On Wed, Jul 20, 2011 at 8:27 PM, Nathaniel Echols <nechols at lbl.gov> wrote:

> On Wed, Jul 20, 2011 at 3:46 AM, G P <gysubscribe at gmail.com> wrote:
> > Now I can make it. I just type labin="FP,SIGFP,DANO,SIGDANO". Then there
> is
> > no error to find the labels. I think because I should give all columns
> > together.
> Right, sorry, that's another thing that CCTBX does automatically.
> This command will show you what array labels Phenix recognizes:
> iotbx.reflection_file_reader data.mtz
> > But there is another problem. When I run the script, it shows me:
> > ...
> > File
> "/usr/local/phenix-1.7.1-743/phaser/phaser/phenix_interface/driver.py",
> > line 694, in __init__
> >     assert os.path.isfile(params.phaser.solution)
> > AssertionError
> > File
> "/usr/local/phenix-1.7.1-743/phaser/phaser/phenix_interface/driver.py",
> > line 694, in __init__
> >     assert os.path.isfile(params.phaser.solution)
> > AssertionError
> Look for a parameter called "solution" - this needs to be left as
> None.  (I don't think there's any way to use this from the command
> line right now - it's very specific to the GUI.)
> -Nat
> _______________________________________________
> phenixbb mailing list
> phenixbb at phenix-online.org
> http://phenix-online.org/mailman/listinfo/phenixbb
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://phenix-online.org/pipermail/phenixbb/attachments/20110720/660b496f/attachment.htm>

More information about the phenixbb mailing list