[phenixbb] external program interference : libwx_gtk2ud-2.8.so.0 not found on ubuntu 64 bit

Nathaniel Echols NEchols at lbl.gov
Tue Oct 27 10:47:14 PDT 2009

On Oct 27, 2009, at 9:01 AM, hari jayaram wrote:
> I just downloaded and installed phenix 1.5.2 . I want to run phenix
> with the GUI on my 64 ubuntu 8.04 box
> When I run phenix I get the following error:
> . . .
> ImportError: libwx_gtk2ud-2.8.so.0: cannot open shared object file: No
> such file or directory
> I know that I should not be getting this error because I have
> wxwidgets and wxpython installed and I have wx working on this machine
> for other apps.
> Consequently I do have a libwx_gtk2ud-2.8.so.0 on my LD_LIBRARY_PATH.
> I tried with and without a libwx_gtk2ud-2.8.so.0 in my LD_LIBRARY_PATH
> and I still got the same error.

The Phenix installer comes with its own local installation of Python,  
wxPython and GTK, because we can't rely on the system having  
compatible versions  (especially on the ancient Linux 2.4 systems).   
Since we don't compile with that particular library, it sounds like it  
is linking against the wrong copy of the wxWidgets and/or GTK shared  
libraries.   What happens if you reset LD_LIBRARY_PATH before  
launching Phenix?  I think this can be done temporarily by using the  
'env' command:

linux% env LD_LIBRARY_PATH="" phenix

Nathaniel Echols
Lawrence Berkeley Lab
NEchols at lbl.gov

More information about the phenixbb mailing list