[phenixbb] external program interference : libwx_gtk2ud-2.8.so.0 not found on ubuntu 64 bit

hari jayaram harijay at gmail.com
Tue Oct 27 09:01:00 PDT 2009

I just downloaded and installed phenix 1.5.2 . I want to run phenix
with the GUI on my 64 ubuntu 8.04 box

When I run phenix I get the following error:

hari at charlie:~$ phenix
Traceback (most recent call last):
  File "/usr/local/phenix-1.5-2/phenix/wxGUI2/command_line/main.py",
line 13, in <module>
  File "/usr/local/phenix-1.5-2/phenix/wxGUI2/command_line/main.py",
line 7, in run
    from wxGUI2 import App
  File "/usr/local/phenix-1.5-2/phenix/wxGUI2/__init__.py", line 109,
in <module>
    import wx
  File "/rawdata12/wx-widgets-read-only/wxPython/wx/__init__.py", line
45, in <module>
    from wx._core import *
  File "/rawdata12/wx-widgets-read-only/wxPython/wx/_core.py", line 4,
in <module>
    import _core_
ImportError: libwx_gtk2ud-2.8.so.0: cannot open shared object file: No
such file or directory

I know that I should not be getting this error because I have
wxwidgets and wxpython installed and I have wx working on this machine
for other apps.
Consequently I do have a libwx_gtk2ud-2.8.so.0 on my LD_LIBRARY_PATH.
I tried with and without a libwx_gtk2ud-2.8.so.0 in my LD_LIBRARY_PATH
and I still got the same error.

Any ideas why phenix GUI does not start?


hari at charlie:~$ which phenix

hari at charlie:~$ echo $LD_LIBRARY_PATH

More information about the phenixbb mailing list