[phenixbb] not enough memory error in Resolve/AutobuildWizard

Thomas C. Terwilliger terwilliger at lanl.gov
Wed Jun 3 09:27:09 PDT 2009

Hi Tatiana,

This may be a little difficult to debug on a cluster...but here goes.

The error message you got comes from


You can see exactly what happens with that command file if you can log on
to a machine in the cluster:

cd AutoBuild_run_1_/TEMP0/AutoBuild_run_1_/TEMP0

then copy temporary.com to test.com and edit test.com to replace all the
material at the top of the file after #!/bin/csh -f (something like this
below) all the way down to "outputdir":

delete all this:
setenv SYMOP
esolve <<EOD > AutoBuild_run_1_/TEMP0/image.log
access_file mirima.dat
workdir AutoBuild_run_1_/TEMP0
outputdir /Users/Shared/unix/transfer/shiven/AutoBuild_run_6_

replace with:

phenix.resolve --huge <<EOD

and then run ./test.com ....it should bomb and tell you what is wrong.

It is possible that the size of your problem is too big for even the 8 GB
of memory on your machine, but that would imply a pretty big cell and
moderate or high resolution.  Hopefully the output of that test will tell

Just to be sure, you might also go to the phenix web site and download a
recent "nightly build" to make sure that there is not some other type of
problem going on.

All the best,
Tom T

>> Hello!
>> I'm trying to run AutobuildWizard on distant computer cluster.
>> Runs failed. In Autobuild log file there is a message:
>> *TRIED resolve_giant ...NEED A BIGGER VERSION...
>> TRIED resolve_giant ...NEED A BIGGER VERSION...
>> TRIED resolve_huge ...NEED A BIGGER VERSION...
>> child process stderr output:
>>   command: 'AutoBuild_run_1_/TEMP0/temporary.com'
>>   Sorry, not enough memory for RESOLVE
>> ----------------------------------
>> TRIED resolve_extra_huge ...but not OK
>> ********************************************************************************
>> Failed to carry out AutoBuild_set_up_build:
>> ********************************************************************************
>> *
>> Some Autobuild runs were ok, some stopped with that error message.
>> What am I doing wrong?
>> I installed Phenix1.4-3, locally to my home folder, run it from script
>> file
>> in queue.
>> As I found this Linux computer cluster has next parameters -
>> 1 login node:
>> -Sun SunFire v20z 1U Rackmount Box
>> -Dual 2.4 GHz AMD Opteron Processors
>> -8 GB of ECC RAM
>> Could you advise something to start with to find a problem?
>> Sincerely,
>> Tanya
>> _______________________________________________
>> phenixbb mailing list
>> phenixbb at phenix-online.org
>> http://www.phenix-online.org/mailman/listinfo/phenixbb

More information about the phenixbb mailing list