[phenixbb] PHENIX on OS X Intel 10.5 "need access to screen" error

Ben Eisenbraun bene at crystal.harvard.edu
Mon Jul 7 13:40:33 PDT 2008

Hi Paul,

>    Is the NFS volume mounted read-only or could there be permissions  
> somehow associated with the mount? I remember that we did have an  
> issue at some point to do with the way that drives were mounted on  
> OSX but the details escape me.

The NFS volume is mounted read-only.  Will this be a problem?  Wouldn't
/usr/local usually be read-only for a regular user?

A little recap, since the situation has changed slightly since my
original post.  I used the source installer on a 10.5 Mac to install to
our NFS directory.  This worked fine on PPC, resulting in a build that
runs on both 10.4 and 10.5 PPC machines.

On the Intel side, it didn't work at all for either 10.4 or 10.5.  They
both return this error:

This program needs access to the screen.
Please run with 'pythonw', not 'python', and only when you are logged
in on the main display of your Mac.

I tried the suggested change from python to pythonw by putting 'pythonw'
in the LIBTBX_PYEXE_BASENAME variable in:


Which actually fixed the 10.4 machine, but still returns the "needs
access" error on 10.5 Intel Macs.  I did a few clean installs from
source to NFS directories on the 10.5 machine to make sure I wasn't
overlooking something simple, but they all fail in this manner.

Any ideas?  wxPython bug?  Weirdo interaction with NFS?  I think I'm
leaning towards a bug in wxPython triggered by the case sensitive file
system, but I haven't taken the time to write a test case that I could
use to verify that.


Ben Eisenbraun
Structural Biology Grid                           Harvard Medical School
http://sbgrid.org                                 http://hms.harvard.edu

More information about the phenixbb mailing list